Sony parchea al menos 4 exploits y cambia las reglas del juego - PSNeo.com
>

Sony parchea al menos 4 exploits y cambia las reglas del juego

VHBL Rip

Ayer fue un día de demasiado ajetreo, con la publicación del Firmware 3.00 de PS Vita y la desagradable sorpresa que se han encontrado algunos desarrolladores, los cuales han visto como sus exploits privados eran parcheados por Sony.

Hoy, con un poco más de calma y analizando los hechos, el desarrollador Acid_Snake ha publicado una entrada en la web de Wololo en la que nos explica más pormenorizadamente lo que ha sucedido. Al menos 4 exploits todavía no públicos de diferentes juegos fueron parcheados por Sony con la actualización de ayer, no obstante, esto no debería alarmar a nadie, si tenemos en cuenta que existen actualmente al menos 30 exploits que se mantienen en secreto, lo que realmente si es un problema es que Sony ha cambiado las reglas del juego, un cambio que hará que muchos juegos con exploit sean ahora incompatibles con el VHBL y TN-V4.

Lo que ha sucedido es básicamente que se ha limitado la carga de los módulos, un punto básico para ejecutar el VHBL. Se ha restringido el uso de los módulos a solamente las importadas por el juego, por lo que si intentamos cargar un módulo que el juego no importe, porque no la necesita para poder funcionar y esta si es necesaria para el funcionamiento del VHBL nos devolverá como resultado un bonito error, así de sencillo.

¿Y en que se traduce esto? Pues en que muchos exploits que antes funcionaban ya no funcionarán porque necesitan uno o varios módulos, otros exploits funcionarán pero su compatibilidad que antes era buena ahora será mucho peor.

En cuanto al TN-V4, al ser un Exploit Kernel, este cambio no afecta a su compatibilidad, pero si que afecta al número de juegos compatibles con él, ya que si para iniciarse TN-V4 necesita cargar ciertas utilidades para acceder a las funciones del exploit y no todas las utilidades están disponibles tampoco se iniciará. Eso sí, una vez se cargue el TN-V4 y como ya había indicado arriba, recalco que no habrá problemas de compatibilidad. No obstante, que nadie se alarme, todavía quedan juegos compatibles con TN-V4.

La mala noticia es que seguramente ahora los desarrolladores se lo pensarán dos veces antes de sacar a la luz un exploit y que esto mata prácticamente al VHBL dejando solamente a los CEF o eCFW (como los queráis llamar, Custom Firmware al fin y al cabo) como solución para los que quieran usar homebrew y emuladores en sus consolas PS Vita.


Publicado por para PSNeo.com el a las 12:42

Comentarios